Join BayouShooter For Free
Meplat

Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16
  1. #11
    Privateer

    User Info Menu

    Still Looking for a H&K certified armorer! I had someone looking at the firearm but no luck. I need to move this forward.

  2. #12
    Not Banned!!!

    User Info Menu

    What is wrong with it?
    "These Rocky Mountains aren't very rocky. Yeah, that John Denver is full of SH**!"

  3. #13
    La. CHP Instructor #409

    Premium Member

    User Info Menu


  4. #14
    Privateer

    User Info Menu

    it is a SP89 clone. It has never functioned properly. it is a failure to to eject the spent case.

  5. #15
    Not Banned!!!

    User Info Menu

    Most likely an issue with the ejector.

    Super easy part to change, I would suggest this one:

    https://www.robertrtg.com/store/pc/M...S-136p2248.htm

    Failing that, most people with clones that have issues end up putting a hk or pof bolt/carrier in the gun.

    You may have an out of spec extractor or a worn extractor spring, but those are not guaranteed to fix an ejection problem.

    The system is very simple. However the interaction with some parts is critical.

    What make is the clone? Bobcat, cohaire?
    "These Rocky Mountains aren't very rocky. Yeah, that John Denver is full of SH**!"

  6. #16
    Privateer

    User Info Menu

    Sorry for the long delay in replying. Like I said the gun was purchased new. You would think there would be no issues but it has never run right. It almost always eats the extracted brass and in doing so will not strip a new round out of the mag. it is a Omega build branded by Kelly enterprises. I would never again buy from that guy. This is not my first H&K (clone) nor is it my first sp89. He would do anything but help me. First he said I wasn't using factory mags- I tried both factory mags and aftermarket. he didn't ask though, just assumed. Everything runs in the HK sp89 nothing in the clone. I needed to shoot 200 rounds through it to loosen it up! Really? Over 2k investment and I need to shoot 200 rounds to loosen it up! Never happened with any other HK I have been around. I was using the wrong ammo. Again the HK ate everything and clone nothing. I had replaced the extractor. I had spares, and the clone ate one once when it was eating brass. It was no help. I took it to a local guy who was more than willing to help. I will use him for other than HK. Brought him a 3rd extractor pin, and he ordered an ejector and replaced the original. still nothing.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •